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PROGRAMMING TOOL – STANDARD  
USER GUIDE  
 
Thank you for purchasing and using Marlin Technologies’ electronic control units. This 
programming tool was created to easily program and configure Marlin Technologies modules. 
The emphasis of the design is ease-of-use and speed of operation. 
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A. Supported USB-CAN dongles 
 

 Kvaser  
a. Leaf Light V2 (https://www.kvaser.com/product/kvaser-leaf-light-hs-v2/) 
b. Leaf Light V3 (https://kvaser.com/product/leaf-v3/) 
c. USB-CAN Pro (https://kvaser.com/product/kvaser-usbcan-professional-2/) 

 PCAN-USB (https://www.gridconnect.com/products/can-usb-adapter-pcan-usb) 
 
 

 
Kvaser Leaf Light v2 

 

          
PCAN-USB 

 
 
 
 
 
 
 



  
Programming Tool - Standard 

User Guide  
 
 

 
 

Programming Tool Page 3 of 36 ©2024 Marlin Technologies, Inc 
 

1. How to install the Programming Tool application  
 
Unzip “MTI ProgTool Installer.zip” file provided by Marlin Technologies, Inc. Locate and run 
“MTI Programming Tool Installer.exe” to initiate the Marlin CAN USB Programmer application 
installation. Follow the prompts during the process until it’s finished. 
 
During installation, you have the option to install drivers for your desired CAN dongle. If you 
don’t already have these drivers, they will need to be installed for the program to run. 
 
 

 
Menu for selecting which CAN Drivers to install 

 
 
 
 
 
 
 
 



  
Programming Tool - Standard 

User Guide  
 
 

 
 

Programming Tool Page 4 of 36 ©2024 Marlin Technologies, Inc 
 

1.1  How to uninstall the application 
To uninstall the application, right click on the windows icon in the taskbar and navigate to 
“Installed apps”. 
 

Menu showing "Installed apps" 

 
Locate “MTI Programming Tool”, click on the 3 dots to the side, and click on “Uninstall” to start 
the uninstall process. 
 

 
Uninstalling the Programming Tool 
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Follow the prompts and wait for the process to complete. The shortcut should disappear from 
your workstation’s Desktop. 
 

 
Uninstallation completion 
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2. Launch the installed application 
After successful installation, a shortcut called “MTI Programming Tool” will appear on the user’s 
desktop. To launch the application, double click it.  
 

 
Shortcut icon for Programming Tool 

Once the program is launched, the application’s main page will appear and an automatic search 
for compatible dongle(s) attached to the computer’s USB port(s) will be performed. 
 
More than one dongle can be connected to the user’s PC workstation at the same time, 
however, only one of them can be active at a given time. 
 

 
Multiple dongles connected 
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Selecting the 'PCAN-USB' dongle 

 
 
Once a dongle is chosen, its name and the current baud rate will appear on the status strip at 
the bottom of the main window highlighted in green. A search for available on CAN bus 
controllers will start automatically. The user can then repeat the search by clicking on the 
“Search” button. 
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If the connected device supports the 0xFFB2 Marlin Beacon Command PGN, an “Identify” 
button will appear. Clicking this button will cause the selected CAN device to flash, useful if 
many of the same device are on the bus. 
 
 
 
 

 
The Identify button on the main menu 
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3. Setting up desired baud rate for a dongle  
The first time you open the application, a default value of 250 kbit/s will be set. To change the 
speed, click on “Tool” -> “Baud Rate:” and pick any of four available rates: 125 kbit/s 250 
kbit/s, 500 kbit/s or 1 Mbit/s. This selection will be remembered after the application is closed. 
 

 
Selecting a baud rate 
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4. Setting up ‘Security’ folder  
If you have a policy requiring the use of a fixed folder containing .s19 files, click on “Security” -
> “File Directory” -> “Lock” to lock the programming tool to a specific folder: 
 
To remove the folder lock, uninstall and reinstall the programming tool as outlined in the 
relevant section of this guide. 
 

 
Locking the file directory 
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Confirmation of directory lock 

Note the “Security” tab has disappeared from the menu. 
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5. Program an .s19 file into a selected controller 
Click on the “Browse” button or go to “File” -> “Open .s19 File”  to choose an .s19 file saved on 
your PC’s hard drive. 
 
Note: do not place your .s19 files into “C:\Program Files (x86)\Marlin 
Technologies\”. The access to this location might be denied by the operating 
system. 
 

 
Button to browse for an .s19 file 

 
.s19 file selected 



  
Programming Tool - Standard 

User Guide  
 
 

 
 

Programming Tool Page 13 of 36 ©2024 Marlin Technologies, Inc 
 

 
Once an .s19 file is selected, the file path will be shown in the text box by the “Browse” button. 
You can now download a program to the selected controller by clicking on the “Program” 
button. During programming, the progress bar will advance and completion percentage will be 
shown, and all buttons are disabled to prevent programming disruption. 
 

 
Device programming in progress 

 
Device programming success 
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6. Program ALL 
 

It is possible to program all Marlin controllers on a CAN bus by clicking on “Prog All” button. The 
user will be prompted to choose a CSV file that contains a list of connected modules and links to 
their .s19 programming files.  

 

Button for programming all devices 

 

 

 

 

 

 



  
Programming Tool - Standard 

User Guide  
 
 

 
 

Programming Tool Page 15 of 36 ©2024 Marlin Technologies, Inc 
 

6.1. Creating a Vehicle Config file 
 

To create a Vehicle Config file for use with the “Prog All” function, navigate to “File” -> “Vehicle 
Config”. 

 

 

Location of Vehicle Config menu 
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Vehicle Config menu 

 

Pressing “Add Modules” will add an empty item to the table, which can be manually filled in.  

Pressing “Add Connected Modules” will populate the table with the module number and source 
address of all currently connected modules. 

Pressing Clear will empty the table. 

Within the table, clicking on an item in the .s19 Filename column will open a file browser, to 
select the desired .s19 file. Clicking on the delete button will delete that row. Use the up and 
down buttons on the right to move the currently highlighted row. 

To load an existing CSV Vehicle Config file, click “Load Vehicle Config” in the toolbar and select 
the desired file. 

To load a deprecated XML Vehicle Config file, click “Load Vehicle Config (Legacy)” in the toolbar 
and select the desired file. 

 To save your configured Vehicle Config file, click “Save Vehicle Config”  
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7. Log CAN Bus traffic 
Check the “Log” -> “J1939” box to log messages sent over the CAN Bus: 
 

 
Location of start logging button 

 
CAN logging in progress 
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To stop logging, click on the “Recording” button or click on “Log” -> “J1939” again. A new log 
file (file extension .asc) will be created and saved to ‘C:\Marlin Data\myLogs\’. 
 

 
CAN logging is complete 

 
The format of the log file is such that it can be used with Vector Informatik CANAlyzer:  
 

 
Format of CAN log 
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8. Loading EEPROM Data from a controller into an XML File 
The user can read and write data to a compatible controller by selecting the “XML” tab: 
 

 
Entering the XML Menu 
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8.1. Single XML 
 

The application will prompt you to choose an .xml template file. After choosing the file, a new 
window will appear. 
 

 
Opened Single XML Menu 

From here, the user can 
- Open a new XML file with the “Open XML” button. 
- Save the currently loaded XML file with “Save As …” 
- Overwrite values/comments using another XML file of the same format with 

“Overwrite Values/Comments” 
- Select which module you want to program with the “Source Address” dropdown 
- Read EEPROM values from the selected module with “Read from EEPROM” 
- Write EEPROM values to the selected module with “Write to EEPROM” 
- Cancel an ongoing R/W operation with “Cancel Operation” 
- Change shown values to a hexadecimal representation by checking the “HEX” 

checkbox 
- Create a read only XML file by checking the “For Dealer” and saving the file. The 

resulting file will read-only. 
o NOTE: Both the Standard and Dealer versions of the Prog Tool can open 

dealer XMLs, but the data cannot be changed. 
- Output a log file when operations are run by checking the “Log Output” checkbox. 
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EEPROM Read operation in progress 

 

Single XML menu in hexadecimal 
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Menu that appears after "Overwrite Values/Comments" is clicked 

 

 

"Log Folder" button appears when Log Output is checked 

 

 
Format of XML R/W Log 
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8.2. Multiple XML 
 

 
Similar to the single XML menu, the application will prompt you to choose an .xml template file. 
After choosing the file, a new table will appear. The user can also save the .xml file by clicking 
‘Save As’ button.  

 

 
Attributes from template XML files populated into a multi tab XML form. 

 
 

Now, the user can: 
- read attributes from all active controllers by pressing ‘Read All Controllers’ 
- modify the attributes’ values and write to the modules by clicking ‘Write All 

Controllers’  
- save attributes as a truck XML file by clicking ‘Save XML Document’ 
- open previously saved truck XML files by clicking ‘Open XML Document’ 
- Cancel an ongoing read/write operation 

             
  Note:  some tabs may contain no information. 
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8.3. Create Multi XML 
 

 
From this menu, you can create a multiple XML file for use with the ‘Multiple XML Configuration’ 
tool.  
 
 
  Note:  All information (other than ‘File Path’) needs to be filled in before a file can 
be saved. Thre user will be notified of an attempt to save an incomplete file. 
 
 
 

 
The 'Create Multi XML' Menu 
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Pressing “Add File” will add an empty item to the table, which can be manually filled in.  

Pressing “Add Connected Modules” will clear and populate the table with the module number 
and source address of all currently connected modules. 

Pressing Clear will empty the table. 

Within the table, clicking on an item in the File Path column will open a file browser, to select 
the desired .xml file. Clicking on the delete button will delete that row. Use the up and down 
buttons on the right to move the currently highlighted row. 

To load an existing Multi XML file, click “Load Multi XML” in the toolbar and select the desired 
file. 

To save your configured Multi XML file, click “Save Multi XML”  
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8.4. Reading EEPROM Data from an ECU into a .txt File  
 
NOTE: Only applies to MTI PN 500812, 500815, and 500841 
 
If your module contains ECU specific data in its EEPROM, you can read its content into a single 
.txt file which will save to ‘C:\Marlin Data\’:   
 
 

 
Reading EEPROM content into a .txt file 
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8.5. Accessing controller’s EEPROM single cell content 
 

The user can read from or write to a single EEPROM memory cell if the controller’s firmware 
allows it. 
 

 

 
Location of EEPROM cell access in main menu 

Click on the ‘EEPROM R/W’ tab on the main window to open the ‘EEPROM R/W’ window. Before 
reading from or writing to a single memory cell, the user should select the desired module on 
the main window. The user can then type in the desired EEPROM address and read or write a 
byte by pressing the corresponding button. 

 

Single EEPROM Read/Write window 
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9. Sending CAN messages to a controller/monitoring CAN traffic 
 

Open the CAN Bus Viewer by clicking on the “CAN” tab. 

 

Location of CAN tab on main menu 

The “Received CAN Messages” table shows all CAN messages sent by modules on the bus after 
opening the page.  
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The Color column can be used to color code received CAN messages. Clicking on the cell will 
open a color picker, which you can use to select a color. 

 

Dropdown to select a color 

 

Color selected 
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The other columns show relevant information on the received CAN messages, including Cycle 
Time (approximate time elapsed between times this PGN was received), CANID, PGN, Source 
Address, CAN Data, and Count (the number of times this PGN was received) 

The “Transmitting CAN Messages” Table can be used to send messages over the CAN bus. 

To add a new message to the “Transmitting CAN Messages” table, click the “Add” button in the 
bottom right of the window. This will open a window for adding a new CAN message 

 

 

Dialog box to add a new CAN message to transmit 

 

In the window to add a new CAN message, you can set the CAN ID, the length of the data, the 
data bytes to be sent. An F key or the space key can be set as a hotkey to send this message. A 
comment can be added to easily identify a particular message. If “Periodic” is checked, you can 
set a period in milliseconds. This will send this message every time this amount of time has 
elapsed. 
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Transmitting CAN Messages section with example messages 

 

Once a new row has been created, it will fill with the information you just entered. To send this 
message, or to start sending a periodic message, press the “Send” or “Start” button, or press 
the mapped key. To stop a periodic message, press the “Stop” button, or press the mapped 
key. This row can be changed or removed using the “Edit” or “Delete” buttons, respectively. 

A CAN log can be started or stopped from this menu by pressing the “Start/Stop CAN Log” 
button in the bottom left corner.  

A particular configuration of the “Transmitting CAN Messages” table (file extension .txcfg) can 
be saved by clicking the “Save Tx” button. These files can then be loaded again by clicking the 
“Load Tx” button. 
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10. Advanced Settings 
Two checkboxes have been added as of 3.0.5, under the “Tool” tab. 

DM13 Stop Broadcast (off by default): Sends out a J1939 DM13 STOP BROADCAST message 
before programming. Only supported my some Marlin modules, particularly those that 
broadcast lots of data over the CAN bus. 

Check Mfg Code (on by default): Filters searched modules by Marlin Technologies manufacturer 
code. 

 

 

Location of advanced settings checkboxes 
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11. Get information about the Programming Tool 
The “Help” tab on the main window contains two options: 

“About…” will open a small window that gives some information about the Programming Tool. 

“User Guide…” will open this document. 

“Programming Resources…” will open a webpage containing information and programming files 
for M-Flex devices. 

 

 

Location of help tab in main menu 
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About tab 

 

Design Resources page on the Marlin Technologies website. 

 

If you have any additional comments, questions, or concerns, please contact Marlin 
Technologies Inc customer service by calling 920-485-4463. 
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Appendix A: Change Log 
 

3.0.0:  

-Initial release 

 

3.0.1:  

 -Updated HWConfigs.xml 

 -Improved how source addresses are selected in the Single XML menu 

 -Better error handling when creating Marlin directories 

 

3.0.2: 

 -Improved EEPROM queries 

 -Module to configure can now be selected from the Single XML menu 

 -Browse button on main window now disabled while searching and programming 

 

3.0.3: 

 -Fixed issue when programming EMC-hardened displays (e.g. 505404) 

 

3.0.4: 

 -Added EEPROM Dump function to Dealer version 

 -Added 505408 and 505411 to the list of modules that support EEPROM dump 

 -Periodic messages no longer continue after CAN window is closed 

 -User is no longer warned about writing a null value XML cell 

 -Fixed issue with empty Tx messages in CAN log 
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3.0.5: 

 -Added DM13 Stop Broadcast checkbox 

 -Added Address Claim Manufacturer Code checkbox 

 -Hitting the “F” and “S” key no longer crashes CAN menu  

3.0.6: 

 -Signed installer 

3.0.7: 

-Modules with HW revisions (i.e. 501214B, 501214C) will now include the letter revision 
in the search menu 

-XML menus now stay aligned when switching between decimal and hex 

-Updated Kvaser Drivers 

-Added support for Kvaser Leaf Light v3 and Kvaser USBcan Pro 

3.0.8: 

-Added progress bar to XML read write operations 

-Added cancel button to XML read write operations 

-Added logging feature for single XML 

-Made CAN menu’s Rx and Tx sections resizable 

-Opened s19 files now persist across sessions 

3.0.9: 

 -Added “Identify Device” PGN 

 -Multi Channel CAN adapters (i.e. USBCan Pro) now show all channels 

 -Dealer XMLs can now be opened in the Standard version, in read-only mode 

 -Updated HWConfigurations.xml to 1.13 


